Modbus master


New member

I am currently utilizing a Raspberry Pi 4 paired with the Building Automation Hat V4. My objective is to establish a connection to an air flow meter through Modbus.

I am using Python in conjunction with the MinimalModbus library. However, when attempting to read a register, I encounter the following error: minimalmodbus.InvalidResponseError: Checksum error in RTU mode:. Upon inspecting the bus traffic with an oscilloscope, it appears that the device is not responding to any signals.

Does anyone have any insights into what might be going wrong?


  • Näyttökuva 2024-02-01 152517.png
    Näyttökuva 2024-02-01 152517.png
    244.9 KB · Views: 4


Staff member
I am guessing you already disable the card modbus interface ( megabas 0 rs485wr 0 0 0 0 0).
At a first look the picture (A and B signals) looks good but sims like your sensor did not respond or you did not record enough time.


New member
Yes, I have disabled it. And I recorded more time, but it was cut off.
Is the voltage, and the variation in voltage, at a reasonable level in your opinion?

Doc Garret

New member
Do you have some more side info about the setup. You are trying to read from the airflow meter, so that would be the master and you should "run" a client.

Also, looks you run modbus over RS485. My experience is, that swapping both A en B wire can help as wel. Just try. Nothing will damage. Just to rule out possible faults.

Otherwise try to use pymodbus. or try modbus poll ( to make contact with the airflow meter.
It will give you a clue to search for the source of the fault.