Industrial I/O board 4-20ma Calibration


New member
Question on the industrial automation card for Rasberry Pi. From the factory I was reading values 3.94 -13.3 in node red when driving the input using a signal generator. I used the same signal generator to calibrate one of the 4-20mA inputs.

I ran the calibration command at at 4mA and at 20mA using this process:
set generator to 4mA run command megaind 1 iincal 2 4
set generator to 20mA run command megaind 1 iincal 2 20

After running the calibration I used the signal generator stepped the signal up by 25% steps and monitored the values received in node-red. Here are my results:
4mA - 4.011 in node red
8mA - 10.719
12mA- 17.289
16mA - 19.913
20mA- 20.05

Why is the scaling off between 4 and 20 but accurate at the ends?


Staff member
This is a strange behavior, can you share the card hardware version?
Can you check your source of signal with a multimeter?(on all points)
Because of the isolated topology of the 4-20mA input port it have some nonlinearity but we did not experienced more than 0.6 mA deviation on the full scale for a calibrated channel.
Can you test with a loopback from the output channel and add a multimeter for reference?


New member
The card is V3.1 (if that is the info you are referring to). My first thought was a bad meter as well. I actually have two loop calibrators (by mistake) and while troubleshooting this I did simulate 4-20 on one and measured it on the other and it was right on.

I also did a reset on the calibration on that individual input and would get the following when driving with meter.

4mA - 4.053 in node red
8mA - 8.011
12mA - 12.348
16mA - 14.244
20mA - 14.237

It almost seems link the input in limited.

I'll try the loop back from the card next. Thanks for the weekend reply.


New member
I ran the 4-20 mA analog outputs with Node-Red and measured with a meter:
4 (in node-red block) - 4.03mA on meter
8 - 8.04mA
12 - 12.05mA
16 - 16.04 mA
20 - 16.5 mA

I ran the reset command on the 4-20mA output and had the same result.
I ran the reset calibration on the 4-20mA input.
Now both the input and output have calibrations reset
I looped that analog output into the analog input
Using node red again I forced the output

output set to 4 - input read 4.105
8 - 8.176
12 - 12.441
16 - 14.139
20 - 14.159


New member
I put a meter in the loop of input to output

4 (in to node red output block) - 4.03mA (meter) - 4.106 on node red input
8 - 8.04mA - 8.18
12 - 12.05mA - 12.425
16 - 16.01 mA - 14.201
20 - 16.28mA - 14.25


New member
Tested all 4 4-20ma input channels. I had similar results on all of them.

Does it matter that I'm using an external power source at 24VDC?
Last edited:


New member
I looked at it again this morning and realized I had 24vdc on the loop power but didn't have 24vdc on the main power input to the board. after I did this every looks to be correct


Staff member
Thank you.
Now it perfectly make sense because even the CPU on the card can be powered from Raspberry 5V, the 4-20mA in circuit needs 5.5V to work and this 5.5V is made from 24V.